aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-08-08 10:54:41 +0100
committerGitHub <[email protected]>2024-08-08 11:54:41 +0200
commit83a334f97df4389ca30cb63e50317a66a82562b9 (patch)
treebe03ceb8abfd97443ab846cfb624d38028f52c74 /CMakeLists.txt
parent9a09eac79b85c846e3a865a9078a3f8ff65a9259 (diff)
downloadHyprland-83a334f97df4389ca30cb63e50317a66a82562b9.tar.gz
Hyprland-83a334f97df4389ca30cb63e50317a66a82562b9.zip
core: Move to C++26 and use native_handle to CLOEXEC the debug fd (#7219)
Requires GCC >= 14 / Clang >= 18 --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc8eafd5..cfbd431f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ else()
endif()
include_directories(. "src/" "subprojects/udis86/" "protocols/")
-set(CMAKE_CXX_STANDARD 23)
+set(CMAKE_CXX_STANDARD 26)
add_compile_options(
-Wall
-Wextra