aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-12-16 19:21:44 +0100
committerGitHub <[email protected]>2024-12-16 19:21:44 +0100
commite06b520427a30f1c86562ad7cc3794bf03b40188 (patch)
tree54cbdf6f61c22d6abc4ef16fe6a5dabdf2542b1a /CMakeLists.txt
parentdab50b3ef3a1bad7f68320538223b6b41d1c6012 (diff)
downloadHyprland-e06b520427a30f1c86562ad7cc3794bf03b40188.tar.gz
Hyprland-e06b520427a30f1c86562ad7cc3794bf03b40188.zip
core: Move regex from stdlib to re2 (#8736)
Moves the regex handling from stdlib to re2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa0d4b03..3441039e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,6 @@ else()
endif()
find_package(OpenGL REQUIRED COMPONENTS ${GLES_VERSION})
-pkg_check_modules(hyprctl_deps REQUIRED IMPORTED_TARGET hyprutils>=0.2.4)
-
pkg_check_modules(aquamarine_dep REQUIRED IMPORTED_TARGET aquamarine>=0.4.5)
pkg_check_modules(hyprlang_dep REQUIRED IMPORTED_TARGET hyprlang>=0.3.2)
pkg_check_modules(hyprcursor_dep REQUIRED IMPORTED_TARGET hyprcursor>=0.1.7)
@@ -131,7 +129,8 @@ pkg_check_modules(
libdrm
libinput
gbm
- gio-2.0)
+ gio-2.0
+ re2)
find_package(hyprwayland-scanner 0.3.10 REQUIRED)