aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorizmyname <[email protected]>2024-10-27 00:49:00 +0500
committerGitHub <[email protected]>2024-10-26 22:49:00 +0300
commitf3f7d3629a632682b1b3acf800f0b5fb10cd48f4 (patch)
treedbcd7a8d7bf3fcf5e8f74e3fcc153888196d229d /CMakeLists.txt
parentc356e425008cba8bd0c87487a2c79b9be4eda2aa (diff)
downloadHyprland-f3f7d3629a632682b1b3acf800f0b5fb10cd48f4.tar.gz
Hyprland-f3f7d3629a632682b1b3acf800f0b5fb10cd48f4.zip
Build with hyprland-session.service (#8251)
Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df919d76..ec8c331e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,9 @@ include(GNUInstallDirs)
set(HYPRLAND_VERSION ${VER})
set(PREFIX ${CMAKE_INSTALL_PREFIX})
set(INCLUDEDIR ${CMAKE_INSTALL_INCLUDEDIR})
+set(BINDIR ${CMAKE_INSTALL_BINDIR})
configure_file(hyprland.pc.in hyprland.pc @ONLY)
+configure_file(systemd/hyprland-session.service.in systemd/hyprland-session.service @ONLY)
set(CMAKE_MESSAGE_LOG_LEVEL "STATUS")
@@ -357,6 +359,11 @@ install(
install(FILES ${CMAKE_SOURCE_DIR}/example/hyprland.desktop
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
+
+# session file -systemd
+install(FILES ${CMAKE_SOURCE_DIR}/systemd/hyprland-systemd.desktop
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
+
# allow Hyprland to find assets
add_compile_definitions(DATAROOTDIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}")
@@ -397,3 +404,6 @@ install(
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hyprland
FILES_MATCHING
PATTERN "*.h*")
+
+#install systemd service
+install(FILES ${CMAKE_BINARY_DIR}/systemd/hyprland-session.service DESTINATION ${CMAKE_INSTALL_LIBDIR}/systemd/user)