aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-03-22 18:34:12 +0000
committerVaxry <[email protected]>2024-03-22 18:45:28 +0000
commit461757e2fb39e166db83858d877fcbd730ece4aa (patch)
treef3f482159ea270de67aceb2d22026c51aa650e71 /CMakeLists.txt
parent397e08c16a7b7e414e8ef466e22fe5d4a581bafc (diff)
downloadHyprland-461757e2fb39e166db83858d877fcbd730ece4aa.tar.gz
Hyprland-461757e2fb39e166db83858d877fcbd730ece4aa.zip
scripts: fix asan patch
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71766a8c..e039ceba 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,7 @@ if(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
message(STATUS "Enabling ASan")
target_link_libraries(Hyprland asan)
+ target_link_libraries(Hyprland ${CMAKE_SOURCE_DIR}/libwayland-server.a)
target_compile_options(Hyprland PUBLIC -fsanitize=address)
endif()