aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2023-07-20 18:29:37 +0200
committervaxerski <[email protected]>2023-07-20 18:29:37 +0200
commit7940f779e9dd670157932ce17a872c14747ad490 (patch)
tree0bcc57dba9ef6341d2b7f3ca428d25a9abd47b3b /CMakeLists.txt
parenta3f6a72a512d1c89788a9fd763baf071fde827c5 (diff)
downloadHyprland-7940f779e9dd670157932ce17a872c14747ad490.tar.gz
Hyprland-7940f779e9dd670157932ce17a872c14747ad490.zip
cmakelists: move tracy to debug section
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 15 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cd77151..61888849 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,21 @@ if(CMAKE_BUILD_TYPE MATCHES Debug OR CMAKE_BUILD_TYPE MATCHES DEBUG)
add_compile_options(-fsanitize=address)
endif()
+ if(USE_TRACY)
+ message(STATUS "Tracy is turned on")
+
+ option( TRACY_ENABLE "" ON)
+ option( TRACY_ON_DEMAND "" ON)
+ add_subdirectory (subprojects/tracy)
+
+ target_link_libraries(Hyprland Tracy::TracyClient)
+
+ if(USE_TRACY_GPU)
+ message(STATUS "Tracy GPU Profiling is turned on")
+ add_compile_definitions(USE_TRACY_GPU)
+ endif()
+ endif()
+
add_compile_options(-pg -no-pie -fno-builtin)
add_link_options(-pg -no-pie -fno-builtin)
endif()
@@ -141,21 +156,6 @@ else()
endif()
endif()
-if(USE_TRACY)
- message(STATUS "Tracy is turned on")
-
- option( TRACY_ENABLE "" ON)
- option( TRACY_ON_DEMAND "" ON)
- add_subdirectory (subprojects/tracy)
-
- target_link_libraries(Hyprland Tracy::TracyClient)
-
- if(USE_TRACY_GPU)
- message(STATUS "Tracy GPU Profiling is turned on")
- add_compile_definitions(USE_TRACY_GPU)
- endif()
-endif()
-
target_compile_definitions(Hyprland
PRIVATE
"GIT_COMMIT_HASH=\"${GIT_COMMIT_HASH}\""