aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormemchr <[email protected]>2023-09-04 17:56:02 +0000
committerGitHub <[email protected]>2023-09-04 19:56:02 +0200
commit8e9f010ee0bae1989279925e8f214bb18c36ba2e (patch)
tree99d691d44e79f22cc3df7b8c44bd6b8bb24073be /CMakeLists.txt
parent4eecb8bffc829ab2222b4acea1942ef8ee7b8904 (diff)
downloadHyprland-8e9f010ee0bae1989279925e8f214bb18c36ba2e.tar.gz
Hyprland-8e9f010ee0bae1989279925e8f214bb18c36ba2e.zip
build: use PCH to reduce compile time (#3095)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 067062c9..a52c798a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,7 @@ endif()
include_directories(
.
+ "src/"
"subprojects/wlroots/include/"
"subprojects/wlroots/build/include/"
"subprojects/udis86/"
@@ -168,6 +169,10 @@ set(CPACK_PROJECT_NAME ${PROJECT_NAME})
set(CPACK_PROJECT_VERSION ${PROJECT_VERSION})
include(CPack)
+message(STATUS "Setting precompiled headers")
+
+target_precompile_headers(Hyprland PRIVATE $<$<COMPILE_LANGUAGE:CXX>:src/pch/pch.hpp>)
+
message(STATUS "Setting link libraries")
target_link_libraries(Hyprland rt PkgConfig::deps)