aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorVESSE Léo <[email protected]>2024-07-17 22:30:02 +0200
committerGitHub <[email protected]>2024-07-17 23:30:02 +0300
commit300228b503b36e5977b0d58713c5b4cf1f07b8a9 (patch)
tree52b9d512d6bbe1cec47088e264ca73a743117cd1 /flake.nix
parent293e687389a19b369f312c5c335c9afe7c886be1 (diff)
downloadHyprland-300228b503b36e5977b0d58713c5b4cf1f07b8a9.tar.gz
Hyprland-300228b503b36e5977b0d58713c5b4cf1f07b8a9.zip
flake: add clang-tools to devShell (#6916)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index c1be8720..88cb593b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -90,9 +90,13 @@
stdenv = pkgsFor.${system}.gcc13Stdenv;
} {
name = "hyprland-shell";
- nativeBuildInputs = with pkgsFor.${system}; [expat libxml2];
+ nativeBuildInputs = with pkgsFor.${system}; [
+ expat
+ libxml2
+ ];
hardeningDisable = ["fortify"];
inputsFrom = [pkgsFor.${system}.hyprland];
+ packages = [pkgsFor.${system}.clang-tools];
};
});