aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-09-14 00:06:43 +0300
committerMihai Fufezan <[email protected]>2024-09-18 18:43:39 +0300
commit6b6554adb8c2fba5d89554af6fc467dcd15cedc0 (patch)
tree952a8c3a972e8fadea3f9b7574f2740d47c79adc /flake.nix
parentd936eb437b5d33cda21e1502a96dc7d83446aca5 (diff)
downloadHyprland-6b6554adb8c2fba5d89554af6fc467dcd15cedc0.tar.gz
Hyprland-6b6554adb8c2fba5d89554af6fc467dcd15cedc0.zip
flake.nix: inherit stdenv from package
Means we no longer have to change the base stdenv in two places.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 9e1e3ab4..ef914627 100644
--- a/flake.nix
+++ b/flake.nix
@@ -95,13 +95,9 @@
devShells = eachSystem (system: {
default =
pkgsFor.${system}.mkShell.override {
- stdenv = pkgsFor.${system}.gcc14Stdenv;
+ inherit (self.packages.${system}.default) stdenv;
} {
name = "hyprland-shell";
- nativeBuildInputs = with pkgsFor.${system}; [
- expat
- libxml2
- ];
hardeningDisable = ["fortify"];
inputsFrom = [pkgsFor.${system}.hyprland];
packages = [pkgsFor.${system}.clang-tools];