diff options
author | Mihai Fufezan <[email protected]> | 2024-04-21 19:58:54 +0300 |
---|---|---|
committer | Mihai Fufezan <[email protected]> | 2024-05-05 16:30:39 +0300 |
commit | f15513309b24790099d42974274eb23f66f7c985 (patch) | |
tree | 07c48555fa44434c9f2a1ed3e8f1ad64111bcf42 /flake.nix | |
parent | 99aa34db6e3529717961cf31ad08ab000d66cd77 (diff) | |
download | Hyprland-f15513309b24790099d42974274eb23f66f7c985.tar.gz Hyprland-f15513309b24790099d42974274eb23f66f7c985.zip |
Nix: use CMake for builds instead of Meson
Build using submodules instead of patching the build process and using
Nix derivations of the subprojects.
From this commit on, you'll have to change the Hyprland flake url to
`git+https://github.com/hyprwm/Hyprland?submodules=1`
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 25 |
1 files changed, 2 insertions, 23 deletions
@@ -7,14 +7,6 @@ # <https://github.com/nix-systems/nix-systems> systems.url = "github:nix-systems/default-linux"; - wlroots = { - type = "github"; - owner = "hyprwm"; - repo = "wlroots-hyprland"; - rev = "5c1d51c5a2793480f5b6c4341ad0797052aec2ea"; - flake = false; - }; - hyprcursor = { url = "github:hyprwm/hyprcursor"; inputs.nixpkgs.follows = "nixpkgs"; @@ -22,12 +14,6 @@ inputs.hyprlang.follows = "hyprlang"; }; - hyprland-protocols = { - url = "github:hyprwm/hyprland-protocols"; - inputs.nixpkgs.follows = "nixpkgs"; - inputs.systems.follows = "systems"; - }; - hyprlang = { url = "github:hyprwm/hyprlang"; inputs.nixpkgs.follows = "nixpkgs"; @@ -44,7 +30,6 @@ url = "github:hyprwm/xdg-desktop-portal-hyprland"; inputs.nixpkgs.follows = "nixpkgs"; inputs.systems.follows = "systems"; - inputs.hyprland-protocols.follows = "hyprland-protocols"; inputs.hyprlang.follows = "hyprlang"; }; }; @@ -92,8 +77,6 @@ # dependencies hyprland-protocols - wlroots-hyprland - udis86 ; }); @@ -103,13 +86,9 @@ stdenv = pkgsFor.${system}.gcc13Stdenv; } { name = "hyprland-shell"; - nativeBuildInputs = with pkgsFor.${system}; [cmake python3 expat libxml2]; - buildInputs = [self.packages.${system}.wlroots-hyprland]; + nativeBuildInputs = with pkgsFor.${system}; [expat libxml2]; hardeningDisable = ["fortify"]; - inputsFrom = [ - self.packages.${system}.wlroots-hyprland - self.packages.${system}.hyprland - ]; + inputsFrom = [pkgsFor.${system}.hyprland]; }; }); |