diff options
author | Huy Nguyen <[email protected]> | 2024-01-17 04:27:35 -0800 |
---|---|---|
committer | GitHub <[email protected]> | 2024-01-17 14:27:35 +0200 |
commit | 8342bac697b7abf036ec1c005af695fb8ab99b13 (patch) | |
tree | 293b06d0ade22133957cd2ee30bb86f4c8f74b02 /flake.nix | |
parent | 3c964a9fdc220250a85b1c498e5b6fad9390272f (diff) | |
download | Hyprland-8342bac697b7abf036ec1c005af695fb8ab99b13.tar.gz Hyprland-8342bac697b7abf036ec1c005af695fb8ab99b13.zip |
Nix: disable fortify for devshell (#4463)
This disables '_FORTIFY_SOURCE' Werrors trying to compile wlroots.
Long standing issue in https://github.com/NixOS/nixpkgs/issues/60919
afaik.
After this change you should be able to:
```
nix develop
mmeson setup build -Dbuildtype=debug
ninja -C build
```
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -86,6 +86,7 @@ name = "hyprland-shell"; nativeBuildInputs = with pkgsFor.${system}; [cmake python3]; buildInputs = [self.packages.${system}.wlroots-hyprland]; + hardeningDisable = [ "fortify" ]; inputsFrom = [ self.packages.${system}.wlroots-hyprland self.packages.${system}.hyprland |