aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2023-12-14 20:02:20 +0200
committerGitHub <[email protected]>2023-12-14 20:02:20 +0200
commitf7cde9c92cb9e7c908f18ecf10ebdb366d0832b5 (patch)
tree7bdc70263a081ea10b0c7a853a208f69cb789ebb /flake.nix
parent01e5c59d752d3fe7fa484330fa48e010054b8fa1 (diff)
downloadHyprland-f7cde9c92cb9e7c908f18ecf10ebdb366d0832b5.tar.gz
Hyprland-f7cde9c92cb9e7c908f18ecf10ebdb366d0832b5.zip
Nix: remove duplicate options from modules (#4012)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 15 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index cd9869d9..6807c0f3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -62,13 +62,16 @@
inherit
(pkgsFor.${system})
# hyprland-packages
+
hyprland
hyprland-unwrapped
hyprland-debug
hyprland-legacy-renderer
# hyprland-extras
+
xdg-desktop-portal-hyprland
# dependencies
+
hyprland-protocols
wlroots-hyprland
udis86
@@ -76,17 +79,18 @@
});
devShells = eachSystem (system: {
- default = pkgsFor.${system}.mkShell.override {
- stdenv = pkgsFor.${system}.gcc13Stdenv;
- } {
- name = "hyprland-shell";
- nativeBuildInputs = with pkgsFor.${system}; [cmake python3];
- buildInputs = [self.packages.${system}.wlroots-hyprland];
- inputsFrom = [
- self.packages.${system}.wlroots-hyprland
- self.packages.${system}.hyprland
- ];
- };
+ default =
+ pkgsFor.${system}.mkShell.override {
+ stdenv = pkgsFor.${system}.gcc13Stdenv;
+ } {
+ name = "hyprland-shell";
+ nativeBuildInputs = with pkgsFor.${system}; [cmake python3];
+ buildInputs = [self.packages.${system}.wlroots-hyprland];
+ inputsFrom = [
+ self.packages.${system}.wlroots-hyprland
+ self.packages.${system}.hyprland
+ ];
+ };
});
formatter = eachSystem (system: nixpkgs.legacyPackages.${system}.alejandra);