aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorCole Mickens <[email protected]>2023-01-18 00:37:56 -0800
committerGitHub <[email protected]>2023-01-18 10:37:56 +0200
commit31ab2349f9f0cad25c9804b5a585617d04cb2a43 (patch)
tree4c301a0245842a106e3b258f436ba9675423632a /flake.nix
parentc31c627cf85ea4fd40c1647c84d89b5e6f186785 (diff)
downloadHyprland-31ab2349f9f0cad25c9804b5a585617d04cb2a43.tar.gz
Hyprland-31ab2349f9f0cad25c9804b5a585617d04cb2a43.zip
nix: react to another stdenv change (#1399)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 15ff9e61..dbd7f8f9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -51,7 +51,7 @@
stdenv = prev.gcc12Stdenv;
version = props.version + "+date=" + (mkDate (self.lastModifiedDate or "19700101")) + "_" + (self.shortRev or "dirty");
wlroots = wlroots-hyprland;
- inherit (inputs.hyprland-protocols.packages.${prev.hostPlatform.system}) hyprland-protocols;
+ inherit (inputs.hyprland-protocols.packages.${prev.stdenv.hostPlatform.system}) hyprland-protocols;
};
hyprland-debug = hyprland.override {debug = true;};
hyprland-no-hidpi = hyprland.override {hidpiXWayland = false;};
@@ -60,8 +60,8 @@
mesonFlags = oldAttrs.mesonFlags ++ ["-Dexperimental=true"];
});
- xdg-desktop-portal-hyprland = inputs.xdph.packages.${prev.hostPlatform.system}.default.override {
- hyprland-share-picker = inputs.xdph.packages.${prev.hostPlatform.system}.hyprland-share-picker.override {inherit hyprland;};
+ xdg-desktop-portal-hyprland = inputs.xdph.packages.${prev.stdenv.hostPlatform.system}.default.override {
+ hyprland-share-picker = inputs.xdph.packages.${prev.stdenv.hostPlatform.system}.hyprland-share-picker.override {inherit hyprland;};
};
};