aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-08-08 10:54:41 +0100
committerGitHub <[email protected]>2024-08-08 11:54:41 +0200
commit83a334f97df4389ca30cb63e50317a66a82562b9 (patch)
treebe03ceb8abfd97443ab846cfb624d38028f52c74 /flake.nix
parent9a09eac79b85c846e3a865a9078a3f8ff65a9259 (diff)
downloadHyprland-83a334f97df4389ca30cb63e50317a66a82562b9.tar.gz
Hyprland-83a334f97df4389ca30cb63e50317a66a82562b9.zip
core: Move to C++26 and use native_handle to CLOEXEC the debug fd (#7219)
Requires GCC >= 14 / Clang >= 18 --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 9c20b3f5..9e1e3ab4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -95,7 +95,7 @@
devShells = eachSystem (system: {
default =
pkgsFor.${system}.mkShell.override {
- stdenv = pkgsFor.${system}.gcc13Stdenv;
+ stdenv = pkgsFor.${system}.gcc14Stdenv;
} {
name = "hyprland-shell";
nativeBuildInputs = with pkgsFor.${system}; [