diff options
author | Vaxry <[email protected]> | 2024-02-18 15:00:34 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2024-02-18 15:00:34 +0000 |
commit | 13f6f0b923ff3ec94a3bec886c28b90402ceef91 (patch) | |
tree | 251f66bfb86416fad0fab18f3b2b2ce87847aa83 /flake.nix | |
parent | 7e8bcd675de15ee2498f1aa15c5b335e9a9a55f0 (diff) | |
download | Hyprland-13f6f0b923ff3ec94a3bec886c28b90402ceef91.tar.gz Hyprland-13f6f0b923ff3ec94a3bec886c28b90402ceef91.zip |
Migrate the config to hyprlang (#4656)
* Migrate to hyprlang
* pop up errors
* fix swapped args
* Meson & Nix: build with hyprlang
* CI: add hyprlang to setup action
* add infra for plugin stuff
* fix hyprctl getoption
* fix hyprctl getoption with json
* format
* fix post parse logic
* fix autogen config
* oops missed exec-once
* fmt
* fix ws rules
* require 0.3.0 for hyprlang
* nix: flaek
* minor type fixes
* fix cfg usages in swipe
* use cvarlist for ws rules
* fix throw in addPluginConfigVar
* Nix: update hyprlang
* minor fixes
* fix disableLogs
* mention hyprlang docs
* bump hyprlang dep in cmake
* Meson: bump min hyprlang version
Nix: update hyprlang
* minor fix
* Nix: update meson patch
---------
Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -22,6 +22,11 @@ inputs.systems.follows = "systems"; }; + hyprlang = { + url = "github:hyprwm/hyprlang"; + inputs.nixpkgs.follows = "nixpkgs"; + }; + xdph = { url = "github:hyprwm/xdg-desktop-portal-hyprland"; inputs.nixpkgs.follows = "nixpkgs"; @@ -86,7 +91,7 @@ name = "hyprland-shell"; nativeBuildInputs = with pkgsFor.${system}; [cmake python3]; buildInputs = [self.packages.${system}.wlroots-hyprland]; - hardeningDisable = [ "fortify" ]; + hardeningDisable = ["fortify"]; inputsFrom = [ self.packages.${system}.wlroots-hyprland self.packages.${system}.hyprland |