aboutsummaryrefslogtreecommitdiffhomepage
path: root/hyprpm/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2023-12-07 10:41:09 +0000
committerGitHub <[email protected]>2023-12-07 10:41:09 +0000
commitd36055054651442db19df046cbdd0697b805c541 (patch)
treed66ec48c6a47cd2b331fe133dc43d57e6d1ec376 /hyprpm/CMakeLists.txt
parent62a8d0be5c1959ade8410f8f964e362288f22175 (diff)
downloadHyprland-d36055054651442db19df046cbdd0697b805c541.tar.gz
Hyprland-d36055054651442db19df046cbdd0697b805c541.zip
hyprpm: Add hyprpm, a Hyprland Plugin Manager (#4072)
Diffstat (limited to 'hyprpm/CMakeLists.txt')
-rw-r--r--hyprpm/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/hyprpm/CMakeLists.txt b/hyprpm/CMakeLists.txt
new file mode 100644
index 00000000..e9cbefa1
--- /dev/null
+++ b/hyprpm/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.19)
+
+project(
+ hyprpm
+ DESCRIPTION "A Hyprland Plugin Manager"
+)
+
+file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
+
+set(CMAKE_CXX_STANDARD 23)
+
+pkg_check_modules(deps REQUIRED IMPORTED_TARGET tomlplusplus)
+
+add_executable(hyprpm ${SRCFILES})