aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorVaxry <[email protected]>2023-10-11 22:27:53 +0100
committerGitHub <[email protected]>2023-10-11 22:27:53 +0100
commit06cc42441cd5b24444f7c79495851dedde8bc732 (patch)
treef923972dc0398dd45e0bc3c9de593ff6fc4e47a5 /meson.build
parent5dc7161b1da7c9ad97122458c94c833b69eb5769 (diff)
downloadHyprland-06cc42441cd5b24444f7c79495851dedde8bc732.tar.gz
Hyprland-06cc42441cd5b24444f7c79495851dedde8bc732.zip
build: guard execinfo.h via build systems (#3547)
* guard execinfo via cmake * libexecinfo -> execinfo macro name * meson: add execinfo check * move check in cmake up --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 726933bc..1d2c7f9f 100644
--- a/meson.build
+++ b/meson.build
@@ -29,6 +29,10 @@ add_project_arguments(
],
language: 'cpp')
+if cpp_compiler.check_header('execinfo.h')
+ add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
+endif
+
wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
have_xwlr = wlroots.get_variable('features').get('xwayland')
xcb_dep = dependency('xcb', required: get_option('xwayland'))