aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authormemchr <[email protected]>2023-10-18 23:09:06 +0000
committerGitHub <[email protected]>2023-10-19 00:09:06 +0100
commitd70cc88dab11bc6d1095523a0ce655dff40b27a2 (patch)
treecd30dfda920964364650e9e6a9895cd03fb53d92 /meson.build
parenta0b675ec9e57af8bc631fc8cc54d062b58669a9f (diff)
downloadHyprland-d70cc88dab11bc6d1095523a0ce655dff40b27a2.tar.gz
Hyprland-d70cc88dab11bc6d1095523a0ce655dff40b27a2.zip
meson: generate version.h before install_headers (#3612)
Otherwise, meson install would not install version.h as a header in a clean build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1d2c7f9f..de29528e 100644
--- a/meson.build
+++ b/meson.build
@@ -69,14 +69,14 @@ if get_option('buildtype') == 'debug'
add_project_arguments('-DHYPRLAND_DEBUG', language: 'cpp')
endif
+version_h = run_command('sh', '-c', 'scripts/generateVersion.sh')
+
globber = run_command('find', 'src', '-name', '*.h*', check: true)
headers = globber.stdout().strip().split('\n')
foreach file : headers
install_headers(file, subdir: 'hyprland', preserve_path: true)
endforeach
-version_h = run_command('sh', '-c', 'scripts/generateVersion.sh')
-
subdir('protocols')
subdir('src')
subdir('hyprctl')