aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorvaxerski <[email protected]>2022-07-06 16:55:49 +0200
committervaxerski <[email protected]>2022-07-06 16:55:49 +0200
commit1599dc47d1d6ba380f524a2937ba84f3fc95f1d6 (patch)
tree0fae87147aad168821c18ae7576baa728c80cf57 /meson.build
parent42d18143e507a9803a402057d29387733292fb43 (diff)
downloadHyprland-1599dc47d1d6ba380f524a2937ba84f3fc95f1d6.tar.gz
Hyprland-1599dc47d1d6ba380f524a2937ba84f3fc95f1d6.zip
set proper C++23 std to meson as well
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 00628761..3f8c68e4 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('Hyprland', 'cpp', 'c',
version : '0.6.2beta',
- default_options : ['warning_level=2', 'cpp_std=c++20', 'default_library=static', 'optimization=3'])
+ default_options : ['warning_level=2', 'cpp_std=c++23', 'default_library=static', 'optimization=3'])
add_project_arguments(
[