aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian sp1rit​ <[email protected]>2022-08-21 00:32:55 +0200
committerFlorian "sp1rit"​ <[email protected]>2022-08-22 14:35:49 +0200
commite9551731f032677a830eb4ab4ea9bcf30857c494 (patch)
tree8c1c174061227a0aa7920f408cac8ecf713f876a /meson.build
parent39a9980fb116108807ee68def27a6348184f282c (diff)
downloadHyprland-e9551731f032677a830eb4ab4ea9bcf30857c494.tar.gz
Hyprland-e9551731f032677a830eb4ab4ea9bcf30857c494.zip
improve compatability with older meson versions
- changed <compiler>.get_version() to <compiler>.version() Signed-off-by: Florian "sp1rit"​ <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 94353336..58ef93a6 100644
--- a/meson.build
+++ b/meson.build
@@ -15,7 +15,7 @@ if cpp_compiler.has_argument('-std=c++23')
elif cpp_compiler.has_argument('-std=c++2b')
add_global_arguments('-std=c++2b', language: 'cpp')
else
- error('Could not configure current C++ compiler (' + cpp_compiler.get_id() + ' ' + cpp_compiler.get_version() + ') with required C++ standard (C++23)')
+ error('Could not configure current C++ compiler (' + cpp_compiler.get_id() + ' ' + cpp_compiler.version() + ') with required C++ standard (C++23)')
endif
GIT_BRANCH = run_command('git', 'rev-parse', '--abbrev-ref', 'HEAD', check: false).stdout().strip()