aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian "sp1rit"​ <[email protected]>2022-06-18 13:09:38 +0200
committerFlorian "sp1rit"​ <[email protected]>2022-06-18 13:09:38 +0200
commit7c3626f15ed25b1d9eb4c14f7e4f887fab2ab62a (patch)
tree4ea1b393a0ecbe64511ff911fd787c5c92305998 /meson.build
parent75918c14d767af3a70010c9d57a0e97bd01a3334 (diff)
downloadHyprland-7c3626f15ed25b1d9eb4c14f7e4f887fab2ab62a.tar.gz
Hyprland-7c3626f15ed25b1d9eb4c14f7e4f887fab2ab62a.zip
meson: ensure non-debug builds will use proper configuration
meson will set add -DHYPRLAND_DEBUG to CXXFLAGS during compilation of debug builds. this avoids NDEBUG issues with wlroots and ensures asserts will also work on release builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 22ee4bf0..b902c80a 100644
--- a/meson.build
+++ b/meson.build
@@ -15,6 +15,10 @@ if not have_xwayland
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DHYPRLAND_DEBUG', language: 'cpp')
+endif
+
subdir('protocols')
subdir('src')
subdir('hyprctl')