aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-09-19 13:48:31 +0000
committerMihai Fufezan <[email protected]>2024-09-19 13:48:31 +0000
commitdfa1bd0cd48253a446fbe455a46f0f4d23368c02 (patch)
treea89cd9caa493624a88c415ed27281927df4fd3b4 /meson.build
parent92df6b0dce1b81b130c2b0e46d206c8c3dbb2971 (diff)
downloadHyprland-dfa1bd0cd48253a446fbe455a46f0f4d23368c02.tar.gz
Hyprland-dfa1bd0cd48253a446fbe455a46f0f4d23368c02.zip
Meson: pass AQUAMARINE_VERSION argument
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 123c31ae..9449c241 100644
--- a/meson.build
+++ b/meson.build
@@ -30,6 +30,9 @@ if cpp_compiler.check_header('execinfo.h')
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
endif
+aquamarine = dependency('aquamarine')
+add_project_arguments(['-DAQUAMARINE_VERSION="@0@"'.format(aquamarine.version())], language: 'cpp')
+
xcb_dep = dependency('xcb', required: get_option('xwayland'))
xcb_composite_dep = dependency('xcb-composite', required: get_option('xwayland'))
xcb_errors_dep = dependency('xcb-errors', required: get_option('xwayland'))