aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian "sp1rit"​ <[email protected]>2022-06-14 16:15:54 +0200
committerFlorian "sp1rit"​ <[email protected]>2022-06-16 23:30:30 +0200
commitd179501c4f4a6b495fc4ded5aec9a1bf04563e95 (patch)
tree8046963a65fe95157fcf5754626ea8d6283ebbe1 /meson.build
parent8e203b0da3fe52d0b8bf22ff9c99d270b7bad160 (diff)
downloadHyprland-d179501c4f4a6b495fc4ded5aec9a1bf04563e95.tar.gz
Hyprland-d179501c4f4a6b495fc4ded5aec9a1bf04563e95.zip
meson: added default_library=static as default option
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2998580c..22ee4bf0 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('Hyprland', 'cpp', 'c',
version : '0.1',
- default_options : ['warning_level=3', 'cpp_std=c++20'])
+ default_options : ['warning_level=3', 'cpp_std=c++20', 'default_library=static'])
wlroots = subproject('wlroots', default_options: ['examples=false'])
have_xwlr = wlroots.get_variable('features').get('xwayland')