aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorjrun <[email protected]>2023-01-05 14:17:55 -0500
committerGitHub <[email protected]>2023-01-05 20:17:55 +0100
commit0d14fd9136d7dbd731b02ce8501ff725f11b71cc (patch)
tree762f31d08fb83a93f32ad9f2b148676b1662833a /meson.build
parent96198dae55b1429449504e49065a10763b288431 (diff)
downloadHyprland-0d14fd9136d7dbd731b02ce8501ff725f11b71cc.tar.gz
Hyprland-0d14fd9136d7dbd731b02ce8501ff725f11b71cc.zip
add systemd support (#1253)
* add systemd support motivation for this is is proper ordering of related/bound/required services to Hyprland (e.g. swaybg) that would need to have a compositor ready. this could possibly be a build-time option of course. see also: example/ files for example of services Signed-off-by: Paymon MARANDI <[email protected]> * nix: add withSystemd flag Signed-off-by: Paymon MARANDI <[email protected]> Co-authored-by: Mihai Fufezan <[email protected]> Co-authored-by: Vaxerski <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3ca2b578..73c84abf 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,16 @@ if not have_xwayland
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
+systemd_dep = dependency('libsystemd', required: get_option('systemd'))
+
+if get_option('systemd').enabled()
+ if systemd_dep.found()
+ add_project_arguments('-DUSES_SYSTEMD', language: 'cpp')
+ else
+ error('Cannot enable systemd in Hyprland: libsystemd was not found')
+ endif
+endif
+
if get_option('buildtype') == 'debug'
add_project_arguments('-DHYPRLAND_DEBUG', language: 'cpp')
endif