aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian "sp1rit"​ <[email protected]>2022-06-14 11:19:03 +0200
committerFlorian "sp1rit"​ <[email protected]>2022-06-16 23:30:30 +0200
commitc169f948951c63b56a4e39dd2ab921676f65f746 (patch)
tree9dc8e4a9d20271fe0593d208a092cb08bdce91a7 /meson.build
parentb3ef1fcc545250b66ae356c4d26e47cbab230b11 (diff)
downloadHyprland-c169f948951c63b56a4e39dd2ab921676f65f746.tar.gz
Hyprland-c169f948951c63b56a4e39dd2ab921676f65f746.zip
moved wlroots/xwayland definitions to the main meson file
prevents build-failure when xwayland is disabled to to add_project_arguments('-DNO_XWAYLAND', language: 'cpp') beeing called after the required wayland protocols have been built.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ea030c23..e09b78ae 100644
--- a/meson.build
+++ b/meson.build
@@ -2,6 +2,19 @@ project('Hyprland', 'cpp', 'c',
version : '0.1',
default_options : ['warning_level=3', 'cpp_std=c++20'])
+wlroots = subproject('wlroots', default_options: ['examples=false'])
+have_xwlr = wlroots.get_variable('features').get('xwayland')
+xcb_dep = dependency('xcb', required: get_option('xwayland'))
+
+if get_option('xwayland').enabled() and not have_xwlr
+ error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
+endif
+have_xwayland = xcb_dep.found() and have_xwlr
+
+if not have_xwayland
+add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
+endif
+
subdir('protocols')
subdir('src')
subdir('hyprctl')