aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-08-08 10:54:41 +0100
committerGitHub <[email protected]>2024-08-08 11:54:41 +0200
commit83a334f97df4389ca30cb63e50317a66a82562b9 (patch)
treebe03ceb8abfd97443ab846cfb624d38028f52c74 /meson.build
parent9a09eac79b85c846e3a865a9078a3f8ff65a9259 (diff)
downloadHyprland-83a334f97df4389ca30cb63e50317a66a82562b9.tar.gz
Hyprland-83a334f97df4389ca30cb63e50317a66a82562b9.zip
core: Move to C++26 and use native_handle to CLOEXEC the debug fd (#7219)
Requires GCC >= 14 / Clang >= 18 --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 886f4f9c..e8cd25b4 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('Hyprland', 'cpp', 'c',
'optimization=3',
'buildtype=release',
'debug=false',
- 'cpp_std=c++23',
+ 'cpp_std=c++26',
])
datarootdir = '-DDATAROOTDIR="' + get_option('prefix') / get_option('datadir') + '"'