aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-09-22 20:53:34 +0300
committerMihai Fufezan <[email protected]>2024-09-27 00:07:52 +0300
commitf75f8efb1be227e586cc0ba2ce6153ce56e04314 (patch)
tree8ab775a82e74ed8e1c125d66d99e20379f72e400 /meson.build
parentbe96787ed086f751455cf713739296b5c6e3a235 (diff)
downloadHyprland-f75f8efb1be227e586cc0ba2ce6153ce56e04314.tar.gz
Hyprland-f75f8efb1be227e586cc0ba2ce6153ce56e04314.zip
Meson: add tracy dependency
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 42ed519d..3545f46a 100644
--- a/meson.build
+++ b/meson.build
@@ -73,6 +73,12 @@ foreach file : headers
install_headers(file, subdir: 'hyprland', preserve_path: true)
endforeach
+tracy = dependency('tracy', static: true, required: get_option('tracy_enable'))
+
+if get_option('tracy_enable') and get_option('buildtype') != 'debugoptimized'
+ warning('Profiling builds should set -- buildtype = debugoptimized')
+endif
+
subdir('protocols')
subdir('src')
subdir('hyprctl')