aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-09-22 21:20:35 +0300
committerMihai Fufezan <[email protected]>2024-09-27 00:07:52 +0300
commit27211c71e92e1bacf111d8a815e958f80969ce6e (patch)
treeeb3600df8383225540304fbb35e1ba8fa90fc5e7 /meson.build
parent14942bca60cc7d85e8238a151bd444112601ebe6 (diff)
downloadHyprland-27211c71e92e1bacf111d8a815e958f80969ce6e.tar.gz
Hyprland-27211c71e92e1bacf111d8a815e958f80969ce6e.zip
Meson: try to find udis86 through pkgconfig, fallback to subproject
Only the fork provides a .pc file, so there's no risk of linking the wrong lib version. If pkg-config can't find it (most cases), fall back to using the subproject through the wrap file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 9449c241..42ed519d 100644
--- a/meson.build
+++ b/meson.build
@@ -43,10 +43,6 @@ xcb_xfixes_dep = dependency('xcb-xfixes', required: get_option('xwayland'))
gio_dep = dependency('gio-2.0', required: true)
-cmake = import('cmake')
-udis = cmake.subproject('udis86')
-udis86 = udis.dependency('libudis86')
-
if not xcb_dep.found()
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif