aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorChing Pei Yang <[email protected]>2023-04-26 23:59:16 +0200
committerGitHub <[email protected]>2023-04-27 00:59:16 +0300
commit38bdbdb0f5356c07f077f238c4e27703e3ff4c1b (patch)
tree47a29c819d327230df1a3aae91529c0c255ca156 /meson.build
parent622132290f60a3ecc1374d1e06eb8d3ddc96af89 (diff)
downloadHyprland-38bdbdb0f5356c07f077f238c4e27703e3ff4c1b.tar.gz
Hyprland-38bdbdb0f5356c07f077f238c4e27703e3ff4c1b.zip
Plugin header overhaul (#2087)
* meson: install headers * Meson/CMake: add pkg-config file for headers * makefile: install headers and pkgconfig * CMake: move protocols to cmake Co-authored-by: Ching Pei Yang <[email protected]> --------- Co-authored-by: Mihai Fufezan <[email protected]> Co-authored-by: vaxerski <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ce371ec3..7d2cdc35 100644
--- a/meson.build
+++ b/meson.build
@@ -75,9 +75,25 @@ if get_option('buildtype') == 'debug'
add_project_arguments('-DHYPRLAND_DEBUG', language: 'cpp')
endif
+globber = run_command('find', 'src', '-name', '*.h*', check: true)
+headers = globber.stdout().strip().split('\n')
+foreach file : headers
+ install_headers(file, subdir: 'hyprland', preserve_path: true)
+endforeach
+
subdir('protocols')
subdir('src')
subdir('hyprctl')
subdir('assets')
subdir('example')
subdir('docs')
+
+pkg_install_dir = join_paths(get_option('datadir'), 'pkgconfig')
+
+import('pkgconfig').generate(
+ name: 'Hyprland',
+ filebase: 'hyprland',
+ url: 'https://github.com/hyprwm/Hyprland',
+ description: 'Hyprland header files',
+ install_dir: pkg_install_dir,
+)