aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorVaxry <[email protected]>2023-02-27 12:32:38 +0000
committerGitHub <[email protected]>2023-02-27 12:32:38 +0000
commit8b81f41e52b55835aaaa7e4962af23a00188cbdc (patch)
treebca65923843ea931c0e0222f29d4e2901cfa8637 /meson.build
parent74a10f26a469de54968e584525f6507928f615f0 (diff)
downloadHyprland-8b81f41e52b55835aaaa7e4962af23a00188cbdc.tar.gz
Hyprland-8b81f41e52b55835aaaa7e4962af23a00188cbdc.zip
Plugin System (#1590)
--------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0ae3d518..f3802553 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,10 @@ wlroots = subproject('wlroots', default_options: ['examples=false'])
have_xwlr = wlroots.get_variable('features').get('xwayland')
xcb_dep = dependency('xcb', required: get_option('xwayland'))
+cmake = import('cmake')
+udis = cmake.subproject('udis86')
+udis86 = udis.dependency('libudis86')
+
if get_option('xwayland').enabled() and not have_xwlr
error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
endif