aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-12-02 16:31:22 +0000
committerGitHub <[email protected]>2024-12-02 16:31:22 +0000
commit92186898c0ca1b3f72922b72c4af1723f0d9b888 (patch)
tree72899d9862d8e23275b51f5f89d5b2945b2b3a0f /meson.build
parent10a9fec7fc8e77479a599985c776a8a184311cd6 (diff)
downloadHyprland-92186898c0ca1b3f72922b72c4af1723f0d9b888.tar.gz
Hyprland-92186898c0ca1b3f72922b72c4af1723f0d9b888.zip
version: add link versions for other utils (#8619)
--------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d825f184..39a5a6d0 100644
--- a/meson.build
+++ b/meson.build
@@ -32,7 +32,13 @@ if cpp_compiler.check_header('execinfo.h')
endif
aquamarine = dependency('aquamarine', version: '>=0.4.5')
+hyprcursor = dependency('hyprcursor', version: '>=0.1.7')
+hyprlang = dependency('hyprlang', version: '>= 0.3.2')
+hyprutils = dependency('hyprutils', version: '>= 0.2.3')
add_project_arguments(['-DAQUAMARINE_VERSION="@0@"'.format(aquamarine.version())], language: 'cpp')
+add_project_arguments(['-DHYPRCURSOR_VERSION="@0@"'.format(hyprcursor.version())], language: 'cpp')
+add_project_arguments(['-DHYPRLANG_VERSION="@0@"'.format(hyprlang.version())], language: 'cpp')
+add_project_arguments(['-DHYPRUTILS_VERSION="@0@"'.format(hyprutils.version())], language: 'cpp')
xcb_dep = dependency('xcb', required: get_option('xwayland'))
xcb_composite_dep = dependency('xcb-composite', required: get_option('xwayland'))