aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/hm-module.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2022-09-03 02:20:20 +0300
committerMihai Fufezan <[email protected]>2022-09-03 02:20:20 +0300
commiteee0cad4d0e58f145432bdcd6dde0b070cd73f14 (patch)
tree5b2f241d9ed2c24f4a69f6677cf51f09f4ab8abb /nix/hm-module.nix
parent0ea96e87c00f15eefbe11916842a4d0bf86c3154 (diff)
downloadHyprland-eee0cad4d0e58f145432bdcd6dde0b070cd73f14.tar.gz
Hyprland-eee0cad4d0e58f145432bdcd6dde0b070cd73f14.zip
Nix modules: fix imports
Diffstat (limited to 'nix/hm-module.nix')
-rw-r--r--nix/hm-module.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/nix/hm-module.nix b/nix/hm-module.nix
index 44316412..d34d604f 100644
--- a/nix/hm-module.nix
+++ b/nix/hm-module.nix
@@ -10,6 +10,14 @@ self: {
hidpiXWayland = cfg.xwayland.hidpi;
};
in {
+ imports = [
+ (
+ lib.mkRenamedOptionModule
+ ["wayland" "windowManager" "hyprland" "xwayland"]
+ ["wayland" "windowManager" "hyprland" "xwayland" "enable"]
+ )
+ ];
+
options.wayland.windowManager.hyprland = {
enable = lib.mkEnableOption "hyprland wayland compositor";
package = lib.mkOption {
@@ -66,14 +74,6 @@ in {
Extra configuration lines to add to ~/.config/hypr/hyprland.conf.
'';
};
-
- imports = [
- (
- lib.mkRenamedOptionModule
- ["wayland" "windowManager" "hyprland" "xwayland"]
- ["wayland" "windowManager" "hyprland" "xwayland" "enable"]
- )
- ];
};
config = lib.mkIf cfg.enable {
@@ -84,7 +84,6 @@ in {
xdg.configFile."hypr/hyprland.conf" = {
text =
(lib.optionalString cfg.systemdIntegration ''
- exec-once=export XDG_SESSION_TYPE=wayland
exec-once=${pkgs.dbus}/bin/dbus-update-activation-environment --systemd DISPLAY WAYLAND_DISPLAY HYPRLAND_INSTANCE_SIGNATURE XDG_CURRENT_DESKTOP
exec-once=systemctl --user start hyprland-session.target
'')