aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/module.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2023-08-14 11:03:01 +0300
committerMihai Fufezan <[email protected]>2023-08-14 11:03:01 +0300
commit314f88de53fc10e218f550a93cc9c9e3974fae71 (patch)
tree7f15d89f8e8d3d165888be09c774354db474fde0 /nix/module.nix
parentaff4a1e237e6270e19b51731046fa9b8af6d313b (diff)
downloadHyprland-314f88de53fc10e218f550a93cc9c9e3974fae71.tar.gz
Hyprland-314f88de53fc10e218f550a93cc9c9e3974fae71.zip
Nix: disable nixpkgs module in ours
Diffstat (limited to 'nix/module.nix')
-rw-r--r--nix/module.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/nix/module.nix b/nix/module.nix
index a5ecee72..907744f8 100644
--- a/nix/module.nix
+++ b/nix/module.nix
@@ -13,6 +13,9 @@ with lib; let
};
};
in {
+ # disables Nixpkgs Hyprland module to avoid conflicts
+ disabledModules = ["programs/hyprland.nix"];
+
options.programs.hyprland = {
enable =
mkEnableOption null
@@ -48,9 +51,11 @@ in {
xwayland.enable = mkEnableOption (mdDoc "support for XWayland") // {default = true;};
- enableNvidiaPatches = mkEnableOption null // {
- description = mdDoc "Whether to apply patches to wlroots for better Nvidia support.";
- };
+ enableNvidiaPatches =
+ mkEnableOption null
+ // {
+ description = mdDoc "Whether to apply patches to wlroots for better Nvidia support.";
+ };
};
config = mkIf cfg.enable {