aboutsummaryrefslogtreecommitdiffhomepage
path: root/protocols/meson.build
diff options
context:
space:
mode:
authorIkalco <[email protected]>2024-07-30 16:33:56 -0500
committerGitHub <[email protected]>2024-07-30 23:33:56 +0200
commit3b9b5346b830554aa7470ccf1202a7f3be72d1b4 (patch)
tree6770e07783bc49414e92bd23e0041971a8b6a360 /protocols/meson.build
parent8ec3dc4c09c30aab7669f99ba6359be320023fa8 (diff)
downloadHyprland-3b9b5346b830554aa7470ccf1202a7f3be72d1b4.tar.gz
Hyprland-3b9b5346b830554aa7470ccf1202a7f3be72d1b4.zip
protocols: Move globalshortcuts impl (#7102)
* move global shortcuts to hyprwayland-scanner * remove wayland-scanner from deps * fix the thing
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build28
1 files changed, 1 insertions, 27 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 4fd40859..5b807914 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -12,21 +12,12 @@ hyprland_protos = dependency('hyprland-protocols',
wl_protocol_dir = wayland_protos.get_variable('pkgdatadir')
hl_protocol_dir = hyprland_protos.get_variable('pkgdatadir')
-wayland_scanner_dep = dependency('wayland-scanner', native: true)
-wayland_scanner = find_program(
- wayland_scanner_dep.get_variable('wayland_scanner'),
- native: true,
-)
hyprwayland_scanner_dep = dependency('hyprwayland-scanner', version: '>=0.3.8', native: true)
hyprwayland_scanner = find_program(
hyprwayland_scanner_dep.get_variable('hyprwayland_scanner'),
native: true,
)
-protocols = [
- [hl_protocol_dir, 'protocols/hyprland-global-shortcuts-v1.xml']
-]
-
new_protocols = [
['wlr-gamma-control-unstable-v1.xml'],
['wlr-foreign-toplevel-management-unstable-v1.xml'],
@@ -40,6 +31,7 @@ new_protocols = [
['wayland-drm.xml'],
['wlr-data-control-unstable-v1.xml'],
['wlr-screencopy-unstable-v1.xml'],
+ [hl_protocol_dir, 'protocols/hyprland-global-shortcuts-v1.xml'],
[hl_protocol_dir, 'protocols/hyprland-toplevel-export-v1.xml'],
[hl_protocol_dir, 'protocols/hyprland-focus-grab-v1.xml'],
[wl_protocol_dir, 'staging/tearing-control/tearing-control-v1.xml'],
@@ -73,24 +65,6 @@ new_protocols = [
wl_protos_src = []
wl_protos_headers = []
-foreach p : protocols
- xml = join_paths(p)
- wl_protos_src += custom_target(
- xml.underscorify() + '_server_c',
- input: xml,
- output: '@[email protected]',
- command: [wayland_scanner, 'private-code', '@INPUT@', '@OUTPUT@'],
- )
- wl_protos_headers += custom_target(
- xml.underscorify() + '_server_h',
- input: xml,
- install: true,
- install_dir: join_paths(get_option('includedir'), 'hyprland/protocols'),
- output: '@[email protected]',
- command: [wayland_scanner, 'server-header', '@INPUT@', '@OUTPUT@'],
- )
-endforeach
-
new_wl_protos = []
foreach p : new_protocols
xml = join_paths(p)