aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/meson.build
diff options
context:
space:
mode:
authorBernhard M. Wiedemann <[email protected]>2023-10-11 20:49:42 +0200
committerGitHub <[email protected]>2023-10-11 19:49:42 +0100
commit5dc7161b1da7c9ad97122458c94c833b69eb5769 (patch)
tree93faf69d9e87729f00325c95164417ddd4ac4f4d /src/meson.build
parent0cf3d5b39a04dd7690dd6bda33fb4bd1194437d9 (diff)
downloadHyprland-5dc7161b1da7c9ad97122458c94c833b69eb5769.tar.gz
Hyprland-5dc7161b1da7c9ad97122458c94c833b69eb5769.zip
meson: Sort input file list (#3550)
so that hyprland builds in a reproducible way in spite of non-deterministic filesystem readdir order. See https://reproducible-builds.org/ for why this is good. This patch was done while working on reproducible builds for openSUSE. Co-authored-by: Bernhard M. Wiedemann <bernhard+gitcommit lsmod.de>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 2065c6f5..0af864b9 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,4 +1,4 @@
-globber = run_command('find', '.', '-name', '*.cpp', check: true)
+globber = run_command('sh', '-c', 'find . -name "*.cpp" | sort', check: true)
src = globber.stdout().strip().split('\n')
executable('Hyprland', src,