aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/meson.build
diff options
context:
space:
mode:
authorHilton Chain <[email protected]>2022-10-28 00:08:03 +0800
committerMihai Fufezan <[email protected]>2022-10-28 00:50:58 +0300
commitc21808dd2dfa85a50d256d975ebee213ab7804ae (patch)
treedbfd38c993e4d9e9e753b10591d3d653d7ce2067 /src/meson.build
parent2c2e35eec1ac2e19a8a4c2178bf58008f797b0a8 (diff)
downloadHyprland-c21808dd2dfa85a50d256d975ebee213ab7804ae.tar.gz
Hyprland-c21808dd2dfa85a50d256d975ebee213ab7804ae.zip
meson: Fallback to 'opengl' when 'GL' is not found.
This patch adds 'opengl' as a fallback to 'GL' for dependency lookup, to link with libglvnd configured without X11 support. For OpenGL, libglvnd provides two pkg-config files: `gl.pc' with GLX support while `opengl.pc' not. When building without X11 support, the former won't be installed.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 5d64188f..f8e995ff 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -18,7 +18,7 @@ executable('Hyprland', src,
xcb_dep,
dependency('pixman-1'),
- dependency('GL'),
+ dependency('GL', 'opengl'),
dependency('threads')
],
install : true