aboutsummaryrefslogtreecommitdiffhomepage
path: root/systemd/meson.build
diff options
context:
space:
mode:
authorPavel Solovev <[email protected]>2024-11-01 13:54:17 +0000
committerMihai Fufezan <[email protected]>2024-11-02 00:20:52 +0200
commit29e7dc642831801d14480cf7e4bb19f6ffb118e9 (patch)
tree1987294365f09f49734ec8a802cdc6a87ad52273 /systemd/meson.build
parent3c0605c68e50416819fea471a8fbef05e4a18684 (diff)
downloadHyprland-29e7dc642831801d14480cf7e4bb19f6ffb118e9.tar.gz
Hyprland-29e7dc642831801d14480cf7e4bb19f6ffb118e9.zip
Systemd fixes
Fix installation path, install the service only if the systemd option is enabled
Diffstat (limited to 'systemd/meson.build')
-rw-r--r--systemd/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/systemd/meson.build b/systemd/meson.build
index 497e64f4..2cd5312a 100644
--- a/systemd/meson.build
+++ b/systemd/meson.build
@@ -7,9 +7,11 @@ install_data(
conf_data = configuration_data()
conf_data.set('PREFIX', get_option('prefix'))
conf_data.set('BINDIR', get_option('bindir'))
+user_unit_dir = systemd.get_variable(pkgconfig: 'systemduserunitdir',
+ pkgconfig_define: ['prefix', get_option('prefix')])
configure_file(
configuration: conf_data,
input: 'hyprland-session.service.in',
output: '@BASENAME@',
- install_dir: join_paths(get_option('libdir'), 'systemd/user') )
+ install_dir: user_unit_dir )