aboutsummaryrefslogtreecommitdiffhomepage
path: root/aur/PKGBUILD-git
diff options
context:
space:
mode:
Diffstat (limited to 'aur/PKGBUILD-git')
-rw-r--r--aur/PKGBUILD-git80
1 files changed, 0 insertions, 80 deletions
diff --git a/aur/PKGBUILD-git b/aur/PKGBUILD-git
deleted file mode 100644
index b6443a2c..00000000
--- a/aur/PKGBUILD-git
+++ /dev/null
@@ -1,80 +0,0 @@
-# Maintainer: ThatOneCalculator <[email protected]>, Sander van Kasteel <[email protected]>
-
-_pkgname="hyprland"
-pkgname="${_pkgname}-git"
-pkgver=r673.gb62e530
-pkgrel=2
-pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
-arch=(any)
-url="https://github.com/vaxerski/Hyprland"
-license=('BSD')
-depends=(
- libxcb
- xcb-proto
- xcb-util
- xcb-util-keysyms
- libxfixes
- libx11
- libxcomposite
- xorg-xinput
- libxrender
- pixman
- wayland-protocols
- cairo
- pango
- polkit
- glslang
- libinput
- libxcb
- libxkbcommon
- opengl-driver
- pixman
- wayland
- xcb-util-errors
- xcb-util-renderutil
- xcb-util-wm
- seatd
- vulkan-icd-loader
- vulkan-validation-layers
- xorg-xwayland)
-makedepends=(
- git
- cmake
- ninja
- gcc
- gdb
- meson
- vulkan-headers
- wayland-protocols
- xorgproto)
-source=("${_pkgname}::git+https://github.com/vaxerski/Hyprland.git")
-conflicts=("${_pkgname}")
-provides=(hyprland)
-sha256sums=('SKIP')
-options=(!makeflags !buildflags)
-
-pkgver() {
- cd "$_pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
-
-build() {
- cd "${srcdir}/${_pkgname}"
- git submodule update --init
- make all
-}
-
-package() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/wayland-sessions"
- mkdir -p "${pkgdir}/usr/share/hyprland"
- install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
- install -Dm755 hyprctl/hyprctl -t "${pkgdir}/usr/bin"
- install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
- install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
- install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
-}