aboutsummaryrefslogtreecommitdiffhomepage
path: root/aur/PKGBUILD-git
diff options
context:
space:
mode:
Diffstat (limited to 'aur/PKGBUILD-git')
-rw-r--r--aur/PKGBUILD-git40
1 files changed, 40 insertions, 0 deletions
diff --git a/aur/PKGBUILD-git b/aur/PKGBUILD-git
new file mode 100644
index 00000000..af0ac400
--- /dev/null
+++ b/aur/PKGBUILD-git
@@ -0,0 +1,40 @@
+# Maintainer: Sander van Kasteel <[email protected]>, ThatOneCalculator <[email protected]>
+
+_pkgname="hyprland"
+pkgname="${_pkgname}-git"
+pkgver=r461.96cdf8f
+pkgrel=5
+pkgdesc="Hyprland is a dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
+arch=(any)
+url="https://github.com/vaxerski/Hyprland"
+license=('BSD')
+depends=(libxcb xcb-proto xcb-util xcb-util-keysyms libxfixes libx11 libxcomposite xorg-xinput libxrender pixman wayland-protocols wlroots-git cairo pango)
+makedepends=(git cmake ninja gcc gdb)
+source=("${_pkgname}::git+https://github.com/vaxerski/Hyprland.git")
+sha256sums=('SKIP')
+options=(!makeflags !buildflags)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make all
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/wayland-sessions"
+ mkdir -p "${pkgdir}/usr/share/hyprland"
+ install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
+ install -Dm755 hyprctl/hyprctl -t "${pkgdir}/usr/bin"
+ install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
+ install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}