aboutsummaryrefslogtreecommitdiffhomepage
path: root/protocols/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build29
1 files changed, 26 insertions, 3 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 857df50f..76dbcacb 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -17,6 +17,11 @@ wayland_scanner = find_program(
wayland_scanner_dep.get_variable('wayland_scanner'),
native: true,
)
+hyprwayland_scanner_dep = dependency('hyprwayland-scanner', native: true)
+hyprwayland_scanner = find_program(
+ hyprwayland_scanner_dep.get_variable('hyprwayland_scanner'),
+ native: true,
+)
protocols = [
[wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
@@ -25,7 +30,6 @@ protocols = [
[wl_protocol_dir, 'unstable/xdg-output/xdg-output-unstable-v1.xml'],
[wl_protocol_dir, 'staging/fractional-scale/fractional-scale-v1.xml'],
[wl_protocol_dir, 'staging/cursor-shape/cursor-shape-v1.xml'],
- [wl_protocol_dir, 'staging/tearing-control/tearing-control-v1.xml'],
['wlr-foreign-toplevel-management-unstable-v1.xml'],
['wlr-layer-shell-unstable-v1.xml'],
['wlr-output-power-management-unstable-v1.xml'],
@@ -36,8 +40,14 @@ protocols = [
[hl_protocol_dir, 'protocols/hyprland-toplevel-export-v1.xml'],
[hl_protocol_dir, 'protocols/hyprland-global-shortcuts-v1.xml']
]
+
+new_protocols = [
+ [wl_protocol_dir, 'staging/tearing-control/tearing-control-v1.xml'],
+]
+
wl_protos_src = []
wl_protos_headers = []
+
foreach p : protocols
xml = join_paths(p)
wl_protos_src += custom_target(
@@ -56,15 +66,28 @@ foreach p : protocols
)
endforeach
+new_wl_protos = []
+foreach p : new_protocols
+ xml = join_paths(p)
+ new_wl_protos += custom_target(
+ xml.underscorify(),
+ input: xml,
+ install: true,
+ install_dir: [false, join_paths(get_option('includedir'), 'hyprland/protocols')],
+ command: [hyprwayland_scanner, '@INPUT@', '@OUTDIR@'],
+ )
+endforeach
+
wayland_server = dependency('wayland-server', version: '>=1.20.0')
lib_server_protos = static_library(
'server_protos',
- wl_protos_src + wl_protos_headers,
+ wl_protos_src + wl_protos_headers + new_wl_protos,
dependencies: wayland_server.partial_dependency(compile_args: true),
)
server_protos = declare_dependency(
link_with: lib_server_protos,
- sources: wl_protos_headers,
+ sources: wl_protos_headers + new_wl_protos,
)