aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <[email protected]>2019-09-09 05:08:41 +0000
committerMatthew Gregan <[email protected]>2019-09-10 10:20:24 +1200
commit797779866bee11adb1a0dc323159be2fabe5584e (patch)
tree8b88176eadae98bf9316489df680e58ab476402c /CMakeLists.txt
parent410c88ee40610a6605f376b637d8a3ae29fb1c0f (diff)
downloadcubeb-797779866bee11adb1a0dc323159be2fabe5584e.tar.gz
cubeb-797779866bee11adb1a0dc323159be2fabe5584e.zip
build: sndio needs -ldl on Linux after 39d20a326f8f
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68d2657..c885793 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -212,7 +212,7 @@ if(USE_SNDIO)
target_sources(cubeb PRIVATE
src/cubeb_sndio.c)
target_compile_definitions(cubeb PRIVATE USE_SNDIO)
- target_link_libraries(cubeb PRIVATE pthread)
+ target_link_libraries(cubeb PRIVATE pthread ${CMAKE_DL_LIBS})
endif()
check_include_files(sys/audioio.h USE_SUN)