aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Adenot <[email protected]>2022-12-13 19:30:46 +0100
committerPaul Adenot <[email protected]>2022-12-13 19:53:21 +0100
commit1353c3383431459b9b3ef469dc1ecb3ec4ec7d69 (patch)
tree95b65e257f356346d3d03c92c39140021170b8b2 /CMakeLists.txt
parente4da2d47c3499320142145f3dbc27204b2d51a59 (diff)
downloadcubeb-1353c3383431459b9b3ef469dc1ecb3ec4ec7d69.tar.gz
cubeb-1353c3383431459b9b3ef469dc1ecb3ec4ec7d69.zip
Add a triple_buffer class that allows publishing data in a wait-free manner from a real-time thread to another thread.
It's largely inspired from the crate cubeb-coreaudio-rs uses, but ported to C++.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7de39f..11951cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -400,6 +400,7 @@ if(BUILD_TESTS)
cubeb_add_test(duplex)
cubeb_add_test(logging)
+ cubeb_add_test(triple_buffer)
if (USE_WASAPI)
cubeb_add_test(overload_callback)