aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Adenot <[email protected]>2023-08-17 17:09:14 +0200
committerPaul Adenot <[email protected]>2023-08-25 20:09:58 +0200
commit33ade008b5befa3a56871e61078d5a5d923bcbf8 (patch)
tree8915e355e16088197747e9659234f42218299913 /CMakeLists.txt
parentac8474a5929e9de3bce84f16f8c589240eb9f7c4 (diff)
downloadcubeb-33ade008b5befa3a56871e61078d5a5d923bcbf8.tar.gz
cubeb-33ade008b5befa3a56871e61078d5a5d923bcbf8.zip
OpenSLES: compile as C++
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dcbc196..e10a99f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,7 +277,7 @@ endif()
check_include_files(SLES/OpenSLES.h USE_OPENSL)
if(USE_OPENSL)
target_sources(cubeb PRIVATE
- src/cubeb_opensl.c
+ src/cubeb_opensl.cpp
src/cubeb-jni.cpp)
target_compile_definitions(cubeb PRIVATE USE_OPENSL)
target_link_libraries(cubeb PRIVATE OpenSLES)