aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Adenot <[email protected]>2024-03-15 13:30:55 +0100
committerPaul Adenot <[email protected]>2024-03-19 16:22:27 +0100
commitaaffe75c25c18bd171b60edc2d5a6f287a9f9808 (patch)
treed850f4d670e9c1e0ec31000ac36aa58dd18e9b24 /CMakeLists.txt
parent5491fc8b2708f80d007a39b86e6b21af90335884 (diff)
downloadcubeb-aaffe75c25c18bd171b60edc2d5a6f287a9f9808.tar.gz
cubeb-aaffe75c25c18bd171b60edc2d5a6f287a9f9808.zip
Fetch avrt.dll functions dynamically again.
Turns out this can crash sometimes, and we need to be more careful. This reverts commit 661c653c8650b2b1c485e86b5a5b4f6d0ed07d1b.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 530e3a4..75955be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -264,7 +264,7 @@ if(USE_WASAPI)
target_sources(cubeb PRIVATE
src/cubeb_wasapi.cpp)
target_compile_definitions(cubeb PRIVATE USE_WASAPI)
- target_link_libraries(cubeb PRIVATE avrt ole32 ksuser)
+ target_link_libraries(cubeb PRIVATE ole32 ksuser)
endif()
check_include_files("windows.h;mmsystem.h" USE_WINMM)