aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Adenot <[email protected]>2023-08-25 10:29:05 -0400
committerPaul Adenot <[email protected]>2023-08-25 20:09:58 +0200
commit3f86a06fcee0ee738db8d0747bf291df8d12ef07 (patch)
tree78ccc992e459b48020b1705edab3be040cd9fe50 /CMakeLists.txt
parent46f10c2eeaeef949a139f1e2b672989895cec98e (diff)
downloadcubeb-3f86a06fcee0ee738db8d0747bf291df8d12ef07.tar.gz
cubeb-3f86a06fcee0ee738db8d0747bf291df8d12ef07.zip
Generate compile_commands.json while building
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e10a99f..2d88f13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ endif()
set(CMAKE_C_STANDARD 99)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
if(USE_SANITIZERS)
if(NOT COMMAND add_sanitizers)