aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <[email protected]>2023-01-21 11:57:03 -0500
committerMatthew Gregan <[email protected]>2023-01-23 14:55:16 +1300
commit67af793663c7f18b37efd7015cafae5a35902de3 (patch)
treed7efac3a3e2a9a95371ba1bcd7ce41c39c42b3c8 /CMakeLists.txt
parentc96f0d4e7ff8843b96719c15f40f1b8032bccba8 (diff)
downloadcubeb-67af793663c7f18b37efd7015cafae5a35902de3.tar.gz
cubeb-67af793663c7f18b37efd7015cafae5a35902de3.zip
cmake: quote CXX_FLAGS substitution for MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11951cf..7b80c73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,8 +71,8 @@ if(NOT MSVC)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter -fno-exceptions -fno-rtti")
else()
- string(REPLACE "/GR" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}) # Disable RTTI
- string(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}) # Disable Exceptions
+ string(REPLACE "/GR" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}") # Disable RTTI
+ string(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}") # Disable Exceptions
endif()
add_library(cubeb