aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <[email protected]>2019-09-05 18:07:37 +0000
committerMatthew Gregan <[email protected]>2019-09-09 13:49:48 +1200
commit7b7bdfc2fe7e926f1a9eec482687b2dd2404d123 (patch)
tree1ad25bac55e13a23d068b2425f43a03da022aafc /CMakeLists.txt
parent552454f621c4791fad63b97885fab207b6335f5c (diff)
downloadcubeb-7b7bdfc2fe7e926f1a9eec482687b2dd2404d123.tar.gz
cubeb-7b7bdfc2fe7e926f1a9eec482687b2dd2404d123.zip
build: explicitly link sndio against -lpthread
/usr/bin/ld.bfd: libcubeb.so: undefined reference to `pthread_create'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 548eaf4..d567c59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -212,7 +212,7 @@ if(USE_SNDIO)
target_sources(cubeb PRIVATE
src/cubeb_sndio.c)
target_compile_definitions(cubeb PRIVATE USE_SNDIO)
- target_link_libraries(cubeb PRIVATE sndio)
+ target_link_libraries(cubeb PRIVATE sndio pthread)
endif()
check_include_files(sys/audioio.h USE_SUN)