aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Adenot <[email protected]>2020-10-28 18:17:19 +0100
committerPaul Adenot <[email protected]>2020-10-30 16:38:43 +0000
commit5a76f201ec45c1bab162960aa091aaf8f6021fcf (patch)
tree13604ef4b8dbfa3e1a87ab1119f87e851d88df15 /CMakeLists.txt
parent05e27634df4a4d595ec1693de3e9f158a55c7101 (diff)
downloadcubeb-5a76f201ec45c1bab162960aa091aaf8f6021fcf.tar.gz
cubeb-5a76f201ec45c1bab162960aa091aaf8f6021fcf.zip
Don't use exception in the new cubeb_aaudio.cpp, and don't build with exception or RTTI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8813c2..f19e2b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,10 @@ endif()
set(CMAKE_CXX_WARNING_LEVEL 4)
if(NOT MSVC)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter -fno-exceptions -fno-rtti")
+else()
+ string(REPLACE "/GR" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}) # Disable RTTI
+ string(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}) # Disable Exceptions
endif()
add_library(cubeb