aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorAyke van Laethem <[email protected]>2023-10-15 15:59:57 +0200
committerRon Evans <[email protected]>2023-10-15 17:51:13 +0200
commit51bed3afae330b8c1b8a87888cc3107cba560c12 (patch)
treeb5ce127aedec4f69398600719bdba5f4743837ab /flake.nix
parent4d4ccddad8ebb1be5246ec889f1ce3a9b9cf9e9e (diff)
downloadtinygo-51bed3afae330b8c1b8a87888cc3107cba560c12.tar.gz
tinygo-51bed3afae330b8c1b8a87888cc3107cba560c12.zip
nix: fix md5sum on MacOS
The default on MacOS is `md5`, while Nix only has `md5sum` available. Therefore, make it possible to override the variable via the environment so that flake.nix can set the correct binary name.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 30e5cde1d..53d8fab45 100644
--- a/flake.nix
+++ b/flake.nix
@@ -72,6 +72,10 @@
export LLVM_AR=llvm-ar
export LLVM_NM=llvm-nm
+ # Make `make smoketest` work (the default is `md5`, while Nix only
+ # has `md5sum`).
+ export MD5SUM=md5sum
+
# Ugly hack to make the Clang resources directory available.
export GOFLAGS="\"-ldflags=-X github.com/tinygo-org/tinygo/goenv.clangResourceDir=${llvmPackages_16.clang.cc.lib}/lib/clang/16"\"
'';