aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorFlavio Castelli <[email protected]>2023-10-16 18:34:20 +0200
committerGitHub <[email protected]>2023-10-16 18:34:20 +0200
commit7019c4e8fcb8a500cc7406bff40b0722fd221acd (patch)
tree0602ef6394b65f6bbaf2bd8ecc6e144dc3c5d607 /flake.nix
parentb79e0e85288056b2b62e118092b0c207c2338007 (diff)
downloadtinygo-7019c4e8fcb8a500cc7406bff40b0722fd221acd.tar.gz
tinygo-7019c4e8fcb8a500cc7406bff40b0722fd221acd.zip
Binaryen116 (#3958)
dependencies: update binaryen submodule to version 116 Signed-off-by: Flavio Castelli <[email protected]> Co-authored-by: DarkByteBen <[email protected]>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 53d8fab45..fd62ebcb3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -18,10 +18,10 @@
#
# But you'll need a bit more to make TinyGo actually able to compile code:
#
-# make llvm-source # fetch compiler-rt
-# git submodule update --init # fetch lots of other libraries and SVD files
-# make gen-device -j4 # build src/device/*/*.go files
-# make wasi-libc # build support for wasi/wasm
+# make llvm-source # fetch compiler-rt
+# git submodule update --init --recursive # fetch lots of other libraries and SVD files
+# make gen-device -j4 # build src/device/*/*.go files
+# make wasi-libc # build support for wasi/wasm
#
# With this, you should have an environment that can compile anything - except
# for the Xtensa architecture (ESP8266/ESP32) because support for that lives in