diff options
author | Andrzej Janik <[email protected]> | 2024-09-04 15:47:42 +0200 |
---|---|---|
committer | GitHub <[email protected]> | 2024-09-04 15:47:42 +0200 |
commit | 193eb29be825370449afb1fe2358f6a654aa0986 (patch) | |
tree | 42ed1179594a362f417266d08842aa186028204a /Cargo.toml | |
parent | 872054ae4000df5eda1dd96f0b4e88dc071c22f9 (diff) | |
download | ZLUDA-193eb29be825370449afb1fe2358f6a654aa0986.tar.gz ZLUDA-193eb29be825370449afb1fe2358f6a654aa0986.zip |
PTX parser rewrite (#267)
Replaces traditional LALRPOP-based parser with winnow-based parser to handle out-of-order instruction modifer. Generate instruction type and instruction visitor from a macro instead of writing by hand. Add separate compilation path using the new parser that only works in tests for now
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -1,5 +1,7 @@ [workspace]
+resolver = "2"
+
members = [
"cuda_base",
"cuda_types",
@@ -15,6 +17,9 @@ members = [ "zluda_redirect",
"zluda_ml",
"ptx",
+ "ptx_parser",
+ "ptx_parser_macros",
+ "ptx_parser_macros_impl",
]
default-members = ["zluda_lib", "zluda_ml", "zluda_inject", "zluda_redirect"]
|